Casual RAID with GRUB

December 2, 2009 at 14:29 | Posted in GRUB, hardware, Linux, RAID, server, software, Ubuntu | Leave a comment

Unexpected hardware complications yields underwhelming results for the server.


dinner’s served
Originally uploaded by limaoscarjuliet

So I got to installing Ubuntu Server the other day. Most of the installation went on smoothly and the OS is now fully installed. Only one catch though. There’s no way to start it.

So it turns out that the server I got was equipped with two harddrives configured for a RAID 1 type of setup. That’s pretty sweet and unexpected in itself as I’ve never had RAID before. And what better place to start using it than on a server?

The only problem is that the standard boot loader for Ubuntu called “GRUB” doesn’t seem to like RAID, at least not the hardware version. In fact, it refused to install with it, and thus I’m left with an unbootable OS.

At the time it was getting late and I just left it for later, but hopefully I’ll be able to get a fix for this before the end of the week. I have an idea to solve it and if that doesn’t work I’ll just have to ask my Ubuntu guru later on.

Fish Tank

November 30, 2009 at 13:02 | Posted in Apache, fish, hardware, Linux, server, Ubuntu, water | Leave a comment

Celend got a fish tank!

Well, she’s had it for a while, but now there’s actual fish swimming around in it! There’s 9 in total, 5 of them being Siamese fighting fish. The rest so far are comprised of platyfish and some Swordtail, both species in the colors of orange and yellow. I have to confess that these critters are far more active that I’d thought. Usually the fish I’ve seen lie about waiting for something to happen, and when that something happens (which usually is feeding time) they become very acive for a short time. Although our fish likes the nom as much as the next one, they just become even more active when food is around and then they tend to swim about freely even when there’s not.

I’ve also aquired the last piece of hardware required to set up the server for now. I was delayed by the fact that it was a Matrox PCI graphics card in it when I got it but not the corresponding cable for connecting DVI or VGA screens to it. Usually I’d just slap in another graphics card, but the motherboard was modern enough to only have a PCI-E slot, and as the only PCI-E card that I have available is currently in my gaming rig I made a pass on putting it in the server. This was however rectified after a trip yesterday to my father’s who’ve graciously donated the computer to begin with after he had no further use of it. So now I’m looking forward to setting it up with Ubuntu Server and slapping making it a LAMP server once I get the time for it later on. I’m hoping it’ll be today.

Soon it’ll be December.

Blog at WordPress.com.
Entries and comments feeds.